路由器服务器名称是什么(服务器网络路由器)
Author
生成
海报
公众号名称

公众号描述

关注
路由器服务器名称是什么(服务器网络路由器)
06-28

我们现在所在的小区大部分还是通过PPPOE拨号方式来上网的,宽带服务提供商会在ISP机房搭建PPPOE服务器。

PPPOE即PPP over Ethernet,是指在以太网中传输PPP的技术,通过PPPoE可以防范ARP欺骗,同时为客户端统一分配IP以及DNS等参数,有效避免了静动态IP方式因地址冲突或者参数设置不当导致无法访问外网的问题,还可以结合Radius服务器对客户进行认证、授权以及计费,目前国内ISP多采用PPPoE作为接入认证方式。

今天我们演示一下,ISP运营商如何配置PPPOE服务器,以及我们上网的路由器如何配置PPPOE拨号登录PPPOE服务器上。

一、配置运营商服务器端

运营商服务器需要配置如下内容:

system-view

[Huawei]sysname ISP

1创建地址池

地址池是分配给拨号用户的可使用的地址范围;

[ISP]ip pool 1

[ISP-ip-pool-1]network 10.10.10.0 mask 24

[ISP-ip-pool-1]gateway-list 10.10.10.254

[ISP-ip-pool-1]dns-list 114.114.114.114

[ISP-ip-pool-1]q

2创建AAA认证

[ISP]aaa

创建用户PPPOE用户名为:1802079,密码为:huawei

[ISP-aaa]local-user 1802099 password cipher huawei

[ISP-aaa]local-user 1802099 service-type ppp //配置服务类型为PPP

若有多个客户端需要登录到PPPOE服务器上,需要创建多个用户;

[ISP-aaa]q

3创建虚拟模板VT接口

VT模板就是为了让一条链路上可以封装多种同层协议的虚拟接口。因为现在的以太网物理接口已经默认封装了以太网协议,无法再封装其他的wan协议了,所以才需要vt来模拟一个(WAN)ppp接口,然后封装其他协议如ppp,最后再把vt绑定到物理接口,实现ppp和以太网协议的嵌套。

[ISP]interface Virtual-Template 1

[ISP-Virtual-Template1]ppp authentication-mode pap //定义PPP采用PAP方式认证,还有Chap认证;

[ISP-Virtual-Template1]remote address pool 1 //指定远端用户地址池;

[ISP-Virtual-Template1]ip address 10.10.10.1 24 //配置本地VT的地址,需与客户端地址池在同一网段,不然用户无法上线。

[ISP-Virtual-Template1]q

4启用PPPOE功能

[ISP]interface GigabitEthernet 0/0/0

[ISP-GigabitEthernet0/0/0]pppoe-server bind virtual-template 1//在接口下绑定虚拟认证模板;

[ISP-GigabitEthernet0/0/0]q

[ISP]

配置完成后,这样vt虚拟接口和连接pppoe客户端的物理以太网接口绑定,完成pppoe协议的封装。

5配置回环口,用来测试

[ISP]interface LoopBack 0

[ISP-LoopBack0]ip address 2.2.2.2 32

[ISP-LoopBack0]q

[ISP]

二、用户客户端配置

system-view

[Huawei]sysname R2

1创建规则,定义允许所有IP

[R2]dialer-rule

[R2-dialer-rule]dialer-rule 1 ip permit

[R2-dialer-rule]q

2配置拨号1

[R2]interface Dialer 1

[R2-Dialer1]link-protocol ppp //封装PPP协议

3创建客户端拨号用户名和密码

[R2-Dialer1]ppp pap local-user 1802099 password cipher huawei

[R2-Dialer1]ip address ppp-negotiate //配置PPPOE客户端自动获取IP地址;

[R2-Dialer1]dialer timer idle 300//设置按需pppoe拨号的空闲时间(300s没有流量就断开)

[R2-Dialer1]dialer timer autodial 5 //重拨时间[R2-Dialer1]dialer useruser1//指定dialer接口拨号所使用的用户,与PPP认证用户一致;

这里的用户名和密码为ISP服务器上建立的用户名;

4关联物理口

[R2-Dialer1]dialer bundle 1

5管理Rule 1

[R2-Dialer1]dialer-group 1

[R2-Dialer1]q

6物理接口建立PPPOE会话

[R2]interface GigabitEthernet 0/0/0

[R2-GigabitEthernet0/0/0]pppoe-client dial-bundle-number1

//这里的1要和第一步的拨号口 1对应;

[R2-GigabitEthernet0/0/0]mtu 1492//修改mtu=1492Byte

[R2-GigabitEthernet0/0/0]q

[R2]

7配置路由器的静态路由

system-view

[R2]ip route-static 0.0.0.0 0 Dialer 1

配置Easy IP并应用到Dialer 1口上

[R2]acl 2000

[R2-acl-basic-2000]rule 5 permit source 192.168.1.0 0.0.0.255

[R2-acl-basic-2000]q

[R2]interface Dialer 1

[R2-Dialer1]nat outbound 2000

[R2-Dialer1]q

[R2]

8定义为PC用户通过dhcp分配ip地址的地址池

[R2]dhcp enable

[R2]ip pool 5

[R2-ip-pool-5]gateway-list 192.168.1.254

[R2-ip-pool-5]network 192.168.1.0 mask 24

[R2-ip-pool-5]dns-list 8.8.8.8

[R2-ip-pool-5]q

9连接用户PC的接口

[R2]interface GigabitEthernet 0/0/1

[R2-GigabitEthernet0/0/1]ip address 192.168.1.254 24

[R2-GigabitEthernet0/0/1]dhcp select global

[R2-GigabitEthernet0/0/1]q

[R2]

配置完成后,在PC3上可以自动获取IP地址等信息。

三、测试

1在企业路由器上查看路由表信息:

display ip interface brief

2查看拨号接口信息

display interface Dialer 1

3查看PPPOE客户端信息

display pppoe-client session summary

4查看PPPOE服务器信息

display pppoe-server session all

主要是验证拨号功能是否生效,这里的MAC地址显示的为客户端的MAC地址;

5测试与VT接口互通

ping 10.10.10.1

6测试与PPPOE服务器互联

7查看地址转换情况,客户WAN口分配的IP地址

[R2]display nat session all

8查看PC自动获取的IP地址:

9、测试本地电脑与ISP服务器互通

测试结果为能够互通,配置完成,欢迎转发。

感谢您的关注,你的支持就是我输出最大的一个动力!

本文由同城头条作者上传并发布,同城头条仅提供信息发布平台。文章仅代表作者个人观点,不代表同城头条立场,未经作者许可,不得转载。
阅读 2

第一次接受赞赏,亲,看着给啊

赞赏
0人赞赏
1
3
5
10
其他金额
金额(元)
赏TA
申请头条作者号

便民信息

更多

推荐阅读

热门评论
随便说点什么
发表评论